What version of PHP will Statamic 3 require?

Seven.

Well, technically you'll need (and want) at least PHP >= 7.1.3.

Statamic 3 will be a Laravel package that supports Laravel 5.6+, which in turn requires PHP 7.1.3. The latest version of Ubunutu (18.04) ships with PHP 7.2, so as long as you have a relatively new server, you should be good to go.

If you need a new host or server, we recommend Digital Ocean. You can run a bunch of Statamic sites on a single $5/mo droplet. It's hard to beat.

Copyright 2019 Statamic